设为首页 收藏本站 站长微博 Email:349323094@qq.com
blogger

软件运行时间(易语言源码)

花街 发布于 编程技术 2018-05-18 [ 961 ] 次浏览 [ 0 ] 条评论

.版本 2
起始时间 = 取启动时间 ()
时钟1.时钟周期 = 1000

.子程序 _时钟1_周期事件
.局部变量 转换后, 文本型
已经过时间 = 取启动时间 () - 起始时间
转换后 = 时间转换 (绝对取整 (已经过时间 ÷ 1000))
.如果真 (转换后 ≠ 标签1.标题)
    标签1.标题 = 转换后
.如果真结束

.子程序 时间转换, 文本型
.参数 时间长度, 整数型
.局部变量 天, 整数型
.局部变量 时, 整数型
.局部变量 分, 整数型
.局部变量 秒, 整数型
时 = 绝对取整 (时间长度 ÷ 3600)
分 = 绝对取整 ((时间长度 - 3600 × 时) ÷ 60)
秒 = 时间长度 - 时 × 3600 - 分 × 60

返回 (选择 (时 > 9, 到文本 (时), “0” + 到文本 (时)) + “天:” + 选择 (时 > 9, 到文本 (时), “0” + 到文本 (时)) + “时:” + 选择 (分 > 9, 到文本 (分), “0” + 到文本 (分)) + “分:” + 选择 (秒 > 9, 到文本 (秒), “0” + 到文本 (秒)) + “秒”)


运行时间.rar大小:1KB | 来源:官方网盘
已经过安全软件检测无毒,请您放心下载。

软件运行时间(易语言源码):等您坐沙发呢!

发表评论